Like Tree1Likes
  • 1 Post By HappyAndyK

Thread: Internet Explorer wont open, load, work or start

  1. #1
    Maroan is offline New Member
    Join Date
    Apr 2014
    Posts
    1

    Default Internet Explorer wont open, load, work or start

    Hello,

    I have the following problem: When I click on the Internet Explorer icon on my desktop, the application doesn't start at all. I have tried from its directory with the same result. I have tried the 64bit version and the no add-ons version as well, same result. On the other hand, Chrome works perfectly.... Any ideas?

  2. #2
    HappyAndyK's Avatar
    HappyAndyK is offline Site Administrator
    Join Date
    Jun 2008
    Posts
    7,339

    Default

    Check if shortcut is defective. Delete it, recreate a new one and try. You say it wont open even when you click on its .exe file in its Program Directory? That's strange!

    Try the following:

    1] Try to open Internet Explorer in No Addons mode and see if it works. If it does, maybe some add-on is interfering. Try to identify it and then disable or remove it.

    2] Re-register ExplorerFrame.dll file. How do do it? Here: Unregister or Register DLL or OCX files in Windows 8 | 7

    3] Run System File Checker: System File Checker: Run sfc /scannow in Windows 7 | 8

    4] Open Run Internet Explorer Performance troubleshooter. Open Run box, type the following and hit Enter:

    %systemroot%\system32\msdt.exe -id IEBrowseWebDiagnostic

    5] Re-register ALL the concerned dll and ocx files and see if it helps. You may use Fix IE.

    Additional links if you need: How To Repair Internet Explorer

    Hope something helps.
    blannykim likes this.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22