Like Tree2Likes
  • 1 Post By Conpreid
  • 1 Post By BillV

Thread: Impersonating_Worker_Thread Blue Screen on Windows 10

  1. #1
    BillV is offline New Member
    Join Date
    Jun 2016
    Posts
    2

    Default Impersonating_Worker_Thread Blue Screen on Windows 10

    We have a computer running Windows 7 Pro. Updated it with Windows 10 Pro and now about every hour we get the following message on a blue screen: IMPERSONATING_WORKER_THREAD Parameters. Information is collected and than the computer reboots it's self and works for another hour and starts this whole process again.

    We tried to figure out if one program was causing it, but could not track it down.

    Any suggestions ?

  2. #2
    HappyAndyK's Avatar
    HappyAndyK is offline Site Administrator
    Join Date
    Jun 2008
    Posts
    7,257

    Default

    Not much information seems to be available on this Stop Error.

    "The IMPERSONATING_WORKER_THREAD indicates that a workitem did not disable impersonation before it completed."

    The only thing I can suggest is that you check if all your device drivers are updated to the latest versions. best to check them at the manufacturers websites.

    Also perform a Clean Boot and see if you are able to isolate the offender.

  3. #3
    Conpreid is offline New Member
    Join Date
    Jun 2016
    Posts
    2

    Default

    Hio, i have the same problem, checkt viruses, harddrive and RAM, all ok.
    The bluescreen problem began last Week with Win7/32. So i made the checks and thought maybe an upgrade to win 10/64 would help, than i made a cleaninstall, both dont fixed it. -.-
    There are more users on other forums with that problem. Im not allowed to post them here. tenforums and chip

    Maybe someone will find the Prob. I think it was an Win update, but it must be published for Win 7 and 10 (read up).

  4. #4
    Conpreid is offline New Member
    Join Date
    Jun 2016
    Posts
    2

    Default

    Norton is the Problem, uninstall it, until they fix it. Many other users are waiting too
    HappyAndyK likes this.

  5. #5
    BillV is offline New Member
    Join Date
    Jun 2016
    Posts
    2

    Default

    Thanks Conpreid, I uninstalled Norton and the problem went away. One would have thought Norton could have had this problem fixed a year later.
    HappyAndyK likes this.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22