1. #1
    shuttered3 is offline New Member
    Join Date
    Sep 2017
    Posts
    1

    Thumbs down Backup problem in Windows 10

    I back up weekly to an external USB connected hard drive with 2T capacity. However, I find that my desktop hard drive has 277g of its total of 280g full.

    This suggests that the hard drive is backing itself up as I have nothing like that amount of data on the machine. When I go into Manage Space via the Control Panel I cannot change anything.

    Can anybody help please? Thank you.

  2. #2
    vasudev's Avatar
    vasudev is offline Moderator
    Join Date
    Nov 2008
    Location
    Bangalore
    Posts
    369

    Default

    Have you turned on Auto back up while setting up your USB External drive for backing up? Also have you checked Backup options in Settings? Open Settings > Update&Security > Backup . Please check various options in that, where you can have which files/folders to exclude, how often to back up etc . This Windows 10 backup works even if you are continuing it since Windows 7 , that can also be stopped.
    Some External drives also comes with their own back up software, check if you are running it by any chance in the background.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22