1. #1
    kkmchan is offline New Member
    Join Date
    Nov 2017
    Posts
    1

    Default USB 3.0 not working or starting. Remains grey in device manager.

    Hello

    I am using Windows 10 Fall Creators Update 1709. The USB 3.0 root hub and xtensible controller 3.0 0.96 microsoft doesn't show up in device manager. Remains grey when I look for hidden devices. Hence I can't use the ports. USB 2.0 starts. I do not have this problem before. Sometimes it showed up after few reboots but most of the time no.

    I have updated the drivers in device manager but to no avail. In windows update there was nothing related to update either. I also tried other methods as suggested in the internet but failed also.

    Thank you.

  2. #2
    HappyAndyK's Avatar
    HappyAndyK is offline Site Administrator
    Join Date
    Jun 2008
    Posts
    7,432

  3. #3
    EriX is offline New Member
    Join Date
    Dec 2017
    Location
    Norway
    Posts
    1

    Default

    Depends on Your mobo - If Asus; check if Al Suite 3 is available, or you have to reinstall Win10 chipset from Asus: support for USB 3.0
    -E

  4. #4
    vasudev's Avatar
    vasudev is offline Moderator
    Join Date
    Nov 2008
    Location
    Bangalore
    Posts
    382

    Default

    Have you tried updating your motherboards chipset driver? Go to your laptops manufacturers or motherboards site and search for these latest drivers from their site.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22