Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    estra is offline Windows Enthusiast
    Join Date
    Jul 2009
    Posts
    143

    Default How to disable: You need to format the disk in drive Z: before you can use it.

    Every time I connect my encrypted USB HDD, the message

    "You need to format the disk in drive Z: before you can use it."

    appears.

    Windows does not know that it is encrypted, and so suggest me to format it right away. And surely I do not want that.

    The same pop-up also appeared in Vista SP1, maybe also vanilla Vista (cannot remember), but Vista SP2 did not have this pop-up.

    Is there perhaps some registry key that can be added or modified, to prevent this pop-up from appearing?

    Thank you.

  2. #2
    HappyAndyK's Avatar
    HappyAndyK is offline Site Administrator
    Join Date
    Jun 2008
    Posts
    6,237

    Default

    Try these options. Hope one of these helps:

    - If you have True Crypt installed, make sure it is installed on your W7 too.

    - Backup the data on the drive and then format to NTFS with W7 and then put the data back.

    - Disable Autoplay.

    - Go to "Computer Management" > "Disk Management" and remove the drive letter.

  3. #3
    estra is offline Windows Enthusiast
    Join Date
    Jul 2009
    Posts
    143

    Default

    I should have mentioned it earlier, but in this case , I am using DiskCryptor for whole disk encryption (disk appears to have no file system, no partitions or files, only raw data). And for that reason, system cannot recognize what is on the drive. TrueCrypt, currently, can only fully encrypt system partition, and create container files on external drives.

    Go to "Computer Management" > "Disk Management" and remove the drive letter.
    That did the trick! Thank you for the great tip!

    Before Vista SP2, where I did not have to make any configuration - this pop-up just did not appear there, I just clicked "No" every time the message appeared. So I got used to the convenience of Vista SP2 and did not want to return to manual labor in Windows 7

    Thanks again!

  4. #4
    HappyAndyK's Avatar
    HappyAndyK is offline Site Administrator
    Join Date
    Jun 2008
    Posts
    6,237

    Default

    Glad something helped. You are welcome, btw.

  5. #5
    coconiqua is offline New Member
    Join Date
    Apr 2010
    Posts
    1

    Default

    I am having the problem "You need to format the disk in drive Z: before you can use it." aND "truecrypt the volume does not contain a recognized file system."

    My regular and regular password load fine but when i put the password for the hidden partition this is what i get. I cant access my fules over there and need them asap. please help!

    (windows 7 btw)
    Last edited by coconiqua; 04-22-2010 at 03:47 PM.

  6. #6
    LeeW is offline Gold Member
    Join Date
    Jan 2010
    Posts
    741

    Default

    Have you checked the Truecrypt forums. I haven't used Truecrypt but seeing your post I researched a bit and seems its quite possibly a bug with the program. Check the Truecrypt forums they may have a workaround. As far as I have read if you cannot get Truecrypt to read the files then I hate to say it but it looks as though the files cannot be decrypted any other way

    TrueCrypt Forums :: Index

  7. #7
    Gew's Avatar
    Gew
    Gew is offline New Member
    Join Date
    May 2010
    Location
    Kingston, Jamaica.
    Posts
    1

    Cool

    Quote Originally Posted by HappyAndyK View Post
    - Go to "Computer Management" > "Disk Management" and remove the drive letter.
    Ty, alot!

  8. #8
    Ville is offline New Member
    Join Date
    May 2010
    Posts
    1

    Default

    The same message also shows up [at least with some] external USB hard drives. I recently had a power outage and had accidentally plugged one of the external USB drives into a standard outlet. As it powered down, then back up again, the same message popped up, suggesting the drive needed to be formatted (it was fine once removed from the system in an orderly way, then plugged back in).

    Since I want to generally access the drive, I can't remove its drive letter. A registry tweak to stop the format offer from popping up would work better.

  9. #9
    Bigboss is offline New Member
    Join Date
    May 2010
    Posts
    2

    Default

    thanks HappyAndyK for the help..i had a similar problem in windows 7 while encrypting USB HDD.

  10. #10
    eager is offline New Member
    Join Date
    Oct 2011
    Posts
    1

    Default

    My daughter got the same message.

    how can i back up the data when i can even see the files or folders...please help.

    she needs to submit her work for assessment.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20