Like Tree1Likes
  • 1 Post By jefeltz

Thread: How to restore File History to a newly formatted drive

  1. #1
    jefeltz is offline New Member
    Join Date
    Sep 2013
    Posts
    2

    Default How to restore File History to a newly formatted drive

    Pretty new Windows 8 computer....got a virus, tough to fix....no big deal, I can reload my OS. One think let to another, and I ended up reformatting my 3 TB hard drive (that is actually set up as a mirrored RAID) that I use for all of my personal files, music, photos. Again, no big deal, because I had been backing the drive using File History to an external USB hard drive that I keep offsite.

    Now I can't figure out how to restore all of this file history back to the 3 TB hard drive. If I open File History and click on "Restore personal files", it says "No file history found". When I click "select drive", it allows me to select my external drive that has the file history data on it. Then it asks me to "select an existing backup". Looking good....it shows a backup listing for the last date I did the backup, but when I click it, I get an error message "Could not reassociate with File History.....Access is denied".

    I AM able to just copy all of the FH files over to the internal hard drive, but FH adds a suffix to all of the file names that seems to indicate the backup set date/name - e.g. IMG_9288 (2013_09_10 03_28_12 UTC).JPG. Also, all of the files are defaulted to read-only.

    Help! I simply want to "restore" these to what is essentially a new hard drive!

  2. #2
    jefeltz is offline New Member
    Join Date
    Sep 2013
    Posts
    2

    Default Solved

    Figured it out w/ MS Tech Support help.

    Rename the File History folder on the external hard drive to "FileHistory.old", then turn on FH and start a new backup set. You can stop that backup after a few minutes (just enough time for the File History directory structure to be set up on the external hard drive).

    Now, move the old File History "Configuration" and "Data" folders underneath the new File History folder. Pay attention to the target path names in the "Config1.xml" file and make sure you have dropped the folders in the right place. You also may need to use file security to take ownership of the files.

    Then restart File History (do not turn it on, just start it). Click "select drive", then select the external drive that has the file history data on it, then "select an existing backup". Ignore warnings that say this is not the latest version of the files. If you get an error about an invalid path, then it just means that the old File History "Configuration" and "Data" files are not in the right place.

    Dig in and try it - it worked!
    HappyAndyK likes this.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22