1. #1
    Ochaye is offline New Member
    Join Date
    Sep 2009
    Posts
    5

    Default How do I switch off auto-defrag in Vista ?

    I've unchecked the "run on a schedule" on Vista's Disk Defragmenter
    but it will still automatically defrag when the machine is idle, if it considers it necessary.

    "virtual" software I'm using will be bolloxed if a defrag occurs while I'm using it.

    So how do I disable auto-defrag in Vista ?

    I didn't see this option on the Tweaker,

    I'm prepared to alter a registry value to switch auto-defrag off.
    Last edited by Ochaye; 15th September 2009 at 18:25. Reason: accuracy

  2. #2
    HappyAndyK's Avatar
    HappyAndyK is offline Site Administrator
    Join Date
    Jun 2008
    Posts
    7,318

  3. #3
    Ochaye is offline New Member
    Join Date
    Sep 2009
    Posts
    5

    Default

    It's probably staring me in the face, but I cannot see the bold items ...

    To disable Vista defrag feature :
    Start > Control Panel > System and Maintenance > Administrative Tools > Defragment your hard drive >
    grant permission > Unclick Run automatically if you want this feature disabled > OK.
    I'm using Vista Windows Home premium, if that's relevant.

    Pehaps there's a line I can put in the command prompt which will switch off auto-defrag ?.
    Last edited by Ochaye; 15th September 2009 at 21:30.

  4. #4
    Ochaye is offline New Member
    Join Date
    Sep 2009
    Posts
    5

    Default

    I suspected a registry change was required ... Disabling Disk Defragmentation

    thanks anyway Andy.

  5. #5
    Ochaye is offline New Member
    Join Date
    Sep 2009
    Posts
    5

    Default Ahhagh!

    Despite changing the registry value to "N" for No, it just did an auto defrag when the machine was idle for +10 minutes.

    Any other suggestions how I can switch this bloody auto defrag thing off.

    [Vista home premium, running on Dell 1525 if that's relevant]
    Last edited by Ochaye; 13th October 2009 at 19:18.

  6. #6
    seti is offline Member
    Join Date
    Nov 2008
    Posts
    1,923

    Default

    Click Start then Computer
    Right Click the C: Drive
    Click on Properties
    Select the Tools Tab
    Click on Defragment Now
    Uncheck Run on a schedule
    this might help

  7. #7
    Ochaye is offline New Member
    Join Date
    Sep 2009
    Posts
    5

    Default

    Quote Originally Posted by seti View Post
    Uncheck Run on a schedule
    this might help
    Thanks Seti,
    but like I said in post #1 I've already done that and it doesn't disable the auto-defrag when idle.

    If I could find the defragment menu option HappyAndyK mentions I'd be laughing ...

    To disable Vista defrag feature :
    Start > Control Panel > System and Maintenance > Administrative Tools > Defragment your hard drive >
    grant permission > Unclick Run automatically if you want this feature disabled > OK.
    but this menu option does not seem to exist on Vista home premium.

    PS I found a possible reason why "N" for No auto defrag didn't stop auto defrag ...
    Check to disable background disk defragmentation.
    Note that if another component h[a]s the two registry keys within it that this option is attempting to disable, then checking this option might have no effect
    Configuring FBWF Offline

    i.e. there could be duplicate registry value(s) somewhere with "Y" for Yes.
    Last edited by Ochaye; 14th October 2009 at 03:26.

  8. #8
    HappyAndyK's Avatar
    HappyAndyK is offline Site Administrator
    Join Date
    Jun 2008
    Posts
    7,318

    Default

    Sorry for the delay in replying. I have erred. It should not be 'Run Automatically ..." but 'Run on a schedule...' which you seem to have already done. I guess I had posted in the earlier thread without remembering the exact wordings.

    Let me see if I can get outside help with this in a day or two ...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22