1. #1
    RankWinner is offline New Member
    Join Date
    Oct 2009
    Posts
    2

    Question Black Screen after Boot

    Hi! I'm having some problems with my computer, after it boots it stays on a black screen for 1-2 mins then it boots up, i've read alot of stories about this but in all of those stories the PC wouldn't boot after te black screen, but mine does.

    P.S. I think this has something to do with a Radeon HD 4850 update, because after I updated it's drivers my computer rebooted with like... 5% brightnes, and I could barley see enought to shut off the computer. So should I uninstall the driver and re-install it? Or is it just a very strange coinsidence?

    Ty for help

  2. #2
    rkonit's Avatar
    rkonit is offline Gold Member
    Join Date
    Jul 2008
    Location
    Pilani, India
    Posts
    1,363

    Default

    Download the latest digitally singned display device dirver and install it.
    Remember: Avoid to Install ATI Catelyst

  3. #3
    iMav's Avatar
    iMav is offline Gold Member
    Join Date
    Jul 2008
    Posts
    921

    Default

    Quote Originally Posted by Ramesh Kumar MVP View Post
    Remember: Avoid to Install ATI Catelyst
    Any particular reason? I've been using Catalyst and haven't had a problem.

  4. #4
    RankWinner is offline New Member
    Join Date
    Oct 2009
    Posts
    2

    Default

    Quote Originally Posted by iMav View Post
    Any particular reason? I've been using Catalyst and haven't had a problem.
    Same! I've been using it since I got my computer, but it only screwd up when I updated it to the latest version... and I like being able to change my fan speed =P

  5. #5
    rkonit's Avatar
    rkonit is offline Gold Member
    Join Date
    Jul 2008
    Location
    Pilani, India
    Posts
    1,363

    Default

    ATI Catelyst insist customize settings on logon screen...and some time crashes due to compatiblity issue with gfx device.

    Even I have ATI gfx and installed updated drivers, but getting few frames are dropped and screen goes blank when I run ATI Catelyst.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22