Up until a day ago, I was always logging into gmail and a game site under the http prefix. That's the way I have the addresses saved in roboform and never noticed even that until now. For some reason when I choose log in feature, IE 9 gets me to the login in page with a http prefix, then when I submit my info and hit submit, when the p[age loads I notice it switched to a https prefix and gives me this error: Internet Explorer cannot display the webpage. I then manually delete the (s) in the https in the address bar, and when I hit enter it switches it back and never loads. I can still enter and get in sites under Mozilla, but when I look at the address bar there, it justs displays ww..... without any http, or https prefix, so that doesn't give me any clues. And I would just use firefox, but my gaming site doesn't take firefox, so I need to get it back working with IE. I have tried uninstalling the update, and installing IE 9 again, but that dooesn't work. I have tried going into internet options, security and changing the levels of values for internet, intranet, and trusted sites, combining with every combination of checking and unchecking Protected mode, combinging that with inside those menus adding my site to each one, and trying the check box with require server verification, and then unchecking, removing the site address in those submenus and checking and unchecking that option for verification of (https), changed the cookie acceptance and pop up blocker settings to allow. I am pretty sure I have covered every possible combination of all those settings. Oh, and the game site won't work in Chrome either. And, I have tried a switch user agent in both Chrome and FF to spoof or mimic IE, and that doesn't work either. I know I can change google settingt to an earlier format which will work but that doesn't help me on the game site. I have some coinage on the game site so I really need to access it and can't figure out how. That is really the only site that I can't seem to figure out a workaround, but it is one I need to get on and access. I hope someone has tackled this problem here and can give me some insight to solve this dilemma. Thanks in advance for any help it is much appreciated!