On my previous platform (Windows 7) the speakers auto switched on and off with the computer. Since upgrading to Windows 10, they remain on unless manually turned on/off. Is there a setting somewhere I need to look at. I've had a look around but can't seem to find anything obvious. Would reinstalling the disk fix it?.