Results 1 to 2 of 2

Thread: System Restore Not Working in Windows 10

  1. #1
    johnkromka is offline New Member
    Join Date
    May 2017

    Default System Restore Not Working in Windows 10

    I haven't used my System Restore in some time, however I tried using it tonight because I downloaded a registry script that was "supposed" to speed up my Windows 10, however it seems to have slowed down things.

    - So I ran the System Restore.- First thing I noticed that was odd was that there was only ONE restore point there and I have my disk usage for restore points set up quite high, so there should have been more than just one restore point and it was three days ago. Anyway, I ran the Restore and was expecting everything to go fine, but it did not.- I noticed it was not finishing in the usual 5-10 minutes.

    - I decided to let it run for a half hour but it would not finish.- It said "Please wait while your Windows files and settings are being restored...System Restore is initializing".- It stayed with exactly this wording the whole 30 minutes.- Then when I restarted the computer it said: "System Restore did not complete successfully.- Your computer files and settings were not changed."- Details: "The System Restore is still in progress and did not complete".

    - So I went looking all over Google for posts on fixing System Restore when it is not working right.- I tried MANY things.- I wish I kept a list of what I tried, but from memory I ran a scannow and it did say it found some corrupted files, but could not fix them all.- It said in one post to try a different restore point, but as I said I only had one, so could not do that.- I ran the Hardware Troubleshooter, found nothing.- I went into Windows Services to make sure all the things associated with Restore were running and on automatic.

    - So now I come to the forum to try and get help to get the SR running right again.- Please give me some other things to try than what I mentioned here.

    - I didn't see this mentioned anywhere but is there any software I can download that might correct the situation?- Is there a 3rd party type of System Restore? (probably not)- As I said I am running Windows 10.- One guy said to go into my Local Group Policy Editor and I looked in vain for that...I don't see it on my system.

    - This is frustrating and I want the SR back.- Thanks for any help. (If this is not in the right forum, sorry, please redirect)

  2. #2
    HappyAndyK's Avatar
    HappyAndyK is offline Site Administrator
    Join Date
    Jun 2008


    Please see if you have tried everything here - System Restore not working in Windows 10/8/7

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22