Results 1 to 4 of 4

Thread: DLL is either not designed to run on Windows or it contains an error

  1. #1
    GoultySoul is offline New Member
    Join Date
    Sep 2017

    Default DLL is either not designed to run on Windows or it contains an error


    We have some interactive whiteboards with Smart education software. When I install the Notebook 14 on the laptop, an error occurs. It says that there is a .dll file in the winSxS fiolder that is either not designed to run on Windows or it contains an error, therefor reinstall the software:

    Bad Image - DLL file is either not designed to run on Windows or it contains an error. Try installing the program again using the original installation media or contact your system administrator or the software vendor for support.

    I reinstalled it 3 times, with the same result.

    My question is: How can I delete this file from the winSxS folder?

    The file is:

    C:\Windows\WinSxS\x86_smarttech.ziparchive.vc100.4 .5_e7e76aadd9f46776_1.0.1.0_none_3edd03d46e05af02\ ZipArchive2010-vc100-mt-x86.dll

    When they first installed this software, it worked but it was a trial version. They deleted the trial version and installed the full version, but when starting the program the error appeared and i can't fix it since. This is a brand new laptop with Win10 Home on it.

    Can someone help?
    Thank You!

  2. #2
    HappyAndyK's Avatar
    HappyAndyK is offline Site Administrator
    Join Date
    Jun 2008


    Deleting the file will not help, as your program does require that particular DLL file for running. It's just that the version of that DLL may have changed and so it may not be working now.

    Contact the software vendor and ask them the version number of that DLL file that is required for proper running on your software. Then see if you can get that DLL file from one of your older trusted systems that may not have this update installed.

    Meanwhile, you could also run System File Checker and see if that helps you.

  3. #3
    keira0607 is offline New Member
    Join Date
    Aug 2017
    United States


    Well, it seems as your DLL file got corrupted or might get changed. So in this case try to repair the software DLL file or download the new one from the trusted sources or Microsoft Official website.

    Also run the SFC scan, or scan for virus/malware as this corrupts the DLL files.

  4. #4
    vasudev's Avatar
    vasudev is offline Moderator
    Join Date
    Nov 2008


    Did uninstalling didn't remove this file? Try uninstalling it & not just delete the program. Were you able to rename it or move to some different folder & then try reinstalling? Try it.
    Also if possible can you go back to a most recent restore point when this was working & then try reinstalling it.
    All this if you are sure that dll is not corrupted as suggested by others. Also try installing on different PC just to check if any update causing this..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22