Results 1 to 6 of 6
Like Tree1Likes
  • 1 Post By develfast

Thread: Right click New Folder creates Shortcut instead!

  1. #1
    mik_m is offline New Member
    Join Date
    Dec 2017

    Question Right click New Folder creates Shortcut instead!

    Hello Gurus

    I’m having a bit of trouble with Windows 10 on my PC.

    A few days ago, I lost the ability to create new items on my Desktop (eg right click>New>Word document). I did a quick Google search and found it was a common problem associated with the loss of a Registry value {D969A300-E7FF-11d0-A93B-00A0C90F2719} in the ‘New’ key under ‘Shellex’. I then downloaded a fix from somewhere and presto! I could then right click and create new items again.

    But, while I can now create new items, something has happened to the ‘New>Folder’ command. When I right click on the Desktop and select New>Folder or I try to create one via the Home>New Folder or Home>New Item>Folder commands in File Explorer, the ‘Create Shortcut’ wizard appears instead of a Folder being created. My guess is that one of the Registry values is pointing towards creating a Shortcut rather than a Folder but I don’t know which Key to look at. I have another Windows 10 PC that I can export a working Key from if only I knew where to look!

    So far, I have imported and replaced the following Keys and Values on the broken PC from the known working PC:

    Computer\HKEY_CLASSES_ROOT\Directory\Background\sh ellex

    Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Direc tory\background\shellex
    Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Direc tory\shellex
    Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Folde r\shellex
    Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Folde r\ShellNew

    I have also made sure that the Key ‘New’ under ‘ContextMenuHandlers’ has the value {D969A300-E7FF-11d0-A93B-00A0C90F2719} wherever that Key occurs.

    As well as playing with the Registry directly, I have tried a System Restore to my last known good configuration, run a Registry cleaner, run a Registry repairer, full virus scan, and a full malware scan. Nothing has helped.

    I’m no expert at this stuff and have spent days scouring sites for an answer but it seems no-one else has had a problem like this before. I really don’t want to do a fresh install for something so small as everything else on the PC is running fine. But having to run a Command Prompt every time I want to create a folder is getting a bit painful!

    Thanks for any help you can provide.


  2. #2
    Pankaj's Avatar
    Pankaj is offline Senior Member
    Join Date
    Nov 2008


    You seem to have tried it all. Create a system restore point and see if this fix works for you. Restore missing NEW context menu item in Explorer

  3. #3
    mik_m is offline New Member
    Join Date
    Dec 2017


    Hi Pankay

    Thanks for getting back to me.

    I tried the fix you suggested but no luck.

    When I first lost the ability to create and new items from the context menu I downloaded a number of similar fixes and applied them (can't remember where from otherwise I could reverse engineer the problem). I now have the option to create a New Folder but when I select this, it brings up the create Shortcut wizard.

    I am temporarily getting around the issue with a batch file of my desktop (using 'md' as the command) but I suspect that to resolve it properly I will need to do a reinstall. Still researching the best way to do this as I would prefer not to lose any apps or settings and my Win 10 is an upgrade from Win 7 Pro so I don't have install disks. Do you have any thoughts on a non-destructive reinstall on an upgraded Win 10 o/s?

    Thanks again.


  4. #4
    JungleBear is offline New Member
    Join Date
    Feb 2018


    Finally Ive found a person that have the exact same problem as I have! This cant be a common thing since theres no valid solution to this problem on the internet!

    Ive tried for weeks now, with every thing you mentioned as well! Except im not smart enough to create the work around you mention!

    I have created this account only because of your thread! Sadly I have no solution, and Im only keen to get in contact with you if you find a fix for this! And hopefully get the problem more attention. Maybe someone out there knows whats going on!

  5. #5
    RolandJS's Avatar
    RolandJS is offline Senior Member
    Join Date
    Dec 2014


    I'm wondering if's Windows Repair (All in One), run in Windows Safe Mode with Networking, might help this situation. After letting it make a registry backup and a System Restore Point, go into Repairs and click what you believe is relevant. Restart once if not twice.

  6. #6
    develfast is offline New Member
    Join Date
    Oct 2018


    Finally!!! I found the solution!!!

    Sorry for the necropost, but I could not find the solution anywhere, save this post mentioning the problem.

    The problem is that in the reg key HKEY_CLASSES_ROOT\Folder\ShellNew there were several keys that should not be there:

    Handler "{ceefea1b-3e29-4ef1-b34c-fec79c4f70af}"
    NullFile ""

    The first one was causing the problem (it creates a New Link)
    When I renamed the first one to "Handler2" it started to create an empty file instead. So I renamed the second one to NullFile2 and it started working!

    There must be an empty string named:
    Directory ""

    For it to work.
    HappyAndyK likes this.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22