Ok, I am stumped, I have a 400 Mb internet connection, three other devices are getting speedtests in the range of ~480 Mb Down, My desktop (Old gaming rig) using two different 1 Gb NICs gets ~130 Mb down.

Troubleshooting steps, I won't list the details of all the Windows changes I have tried, but I have tried just about every one that seemed to apply. Tried known good cat 5E and cat 6 cables, tried different ports on th ASUS router, tried direct connection to Cable Modem, Tried updated and even downgraded drivers for both NICs.

I just can not think of anything else to try.

Specs for devices:
PC: ASUS m4a78pro with AMD Phenom 9500 quad core at 2200.0 MHz

NIC1: RealTek Semiconductor RTL8168B/8111B PCI-E Gigabit Ethernet Adapter On-Board

NIC2: TP-Link TG-3269 PCI adapter



Both are 1 Gb capable NICs. and they do show as being connected at 1 GB in the properties. So I am totally flummoxed and at a stand still in fixing this. If anyone has any ideas or needs more information just let me know. And thanks in advance.