Results 1 to 4 of 4

Thread: Computer has become invisible on network

  1. #1
    TBernstein is offline New Member
    Join Date
    Jul 2019
    Posts
    6

    Default Computer has become invisible on network

    One of my PCs has become invisible to the other machines on a simple network, though it can still see them and access shared folders on them. The other machines can not see the shares on this machine. They can see shares on each other.
    I've checked that discovery is switched on.
    I've made sure that the services required ( according to various posts found by Googling) are running. I've run SFC. I've reset the network.
    The errant machine doesn't even show up on the other PCs and mapped folders won't reconnect.
    It doesn't even show up in network on itself. It can't be accessed by typing the path \\name..
    But, it does see shared folders on the other PCs ( 2 of them). In short Machine A can still access B and C. B and C can see each other. But neither can access A.
    What can I try next?
    It has worked fine for years. All of a sudden I can't get network access to all the documents and pictures stored on this PC. Needless to say it's the one I use for main storage,so it's a real nuisance.
    Any help would be really appreciated.


  2. #2
    TBernstein is offline New Member
    Join Date
    Jul 2019
    Posts
    6

    Default

    Small addition. I did another reset. Now the icon for the inaccessible PC has reappeared in all three PCs' network places. Clicking on that icon locally on its own machine shows the shared folders in the usual way.
    But clicking on it on the other machines and it still says it can't connect.
    It's as if something is stopping network devices from looking at the shared folders.
    I've tried turning off the Windows Firewall and Kaspersky AV.
    Hasn't helped.

  3. #3
    TBernstein is offline New Member
    Join Date
    Jul 2019
    Posts
    6

    Default

    Sorry again. Because I can't edit the post. The display of local shares in network places only, when I tried, showed the shared folders, not their contents - which is even more confusing. And after a reboot that disappeared again.
    And now even my VNC server has stopped responding. It's as if the PC was blocking all external network traffic. But I can't find any setting to allow it back in that isn't already open to it.
    Please help. As well as inconvenient it's also making my brain hurt.

  4. #4
    TBernstein is offline New Member
    Join Date
    Jul 2019
    Posts
    6

    Default

    Solved- though not full understood how it could have happened.
    I went again through all the settings. Then one post said to check SMB was running. Which I thought was weird, why would it not be?
    But it wasn't! SMBv1 had been turned off- it's not secure. But the SMBv2 had vanished. Supposedly turning SMBv1 back on would force it to upgrade to v2. But that didn't happen. But that at least meant the other devices could try to connect and complain that I was running v1. And then I could find a way to install SMBv2 by Googling it- which lead to a Powershell command that installed SMBv2.
    And now everything works again.
    But how SMBv2 (or 3,which remains a mystery)could just vanish is strange. I'd suspect the Windows May update to 1903- except my other devices haven't had the problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22