Results 1 to 4 of 4

Thread: Poor perfomance - disk at 100% all the time

  1. #1
    bcreighton is offline New Member
    Join Date
    Nov 2019
    Posts
    3

    Default Poor perfomance - disk at 100% all the time

    Ok, I don't really understand what is locking up the performance of my computer. It has 4 Gb of Ram and an i5-2400 CPU. I am using a Chrome based browser which uses about 1.6-1.8 Gb of Ram with a lot of tabs open and while streaming on Xfinity. However, at default settings the task manager shows the hard drive at 100% usage all too often, but I don't really see any Apps which are using up the HD. Nevertheless, I went into settings and turned off Skype, YourPhone, Edge, MobilePlans, and a few other extraneous apps. Now, my task manager usually shows there is plenty of disk availability. I don't really understand why this is so. Task manager didn't ever seem to show these apps used much or any Hard Drive. Anyway my HD usage now normally seems to hover around 20% while streaming. I am wondering why these 6 apps seem to affect the performance so much, when Task Manager shows they don't use much memory or HD individually. Are they infected maybe?
    Thanks in advance.


  2. #2
    RolandJS's Avatar
    RolandJS is offline Senior Member
    Join Date
    Dec 2014
    Posts
    159

    Default

    I thought W10 needs a lot more than 4GB RAM to function well. 8-16GB is not unheard of. Without sufficient RAM, your Windows is resorting to many many disk read/writes rather than using RAM, and that can be called "harddrive thrashing" on the extreme end. W10 is running numerous services in the background pretty much constantly -- even though you turned off some stuff.
    Last edited by RolandJS; 2nd December 2019 at 16:21.

  3. #3
    bcreighton is offline New Member
    Join Date
    Nov 2019
    Posts
    3

    Default

    Well, I think I have found the problem. I apparently have an old SATA driver with a bug which causes the disk usage to go up around 100%. When I turned stuff off, that seemed to stop the issue temporarily, but after awhile (a day or so) the disk usage would invariably return to around 100%, and it just made using the computer really unbearably tedious. I have the exact SATA driver mentioned in this web page: makeuseof.com/tag/4-tips-fix-100-disk-usage-improve-windows-performance/#pcie
    I changed the data value to 0 in the registry, and so far it is doing marvelously. Just thought I'd mention that for the benefit of others with the HDD usage issue. I think I need to update my SATA firmware.

  4. #4
    bcreighton is offline New Member
    Join Date
    Nov 2019
    Posts
    3

    Default

    I have had no success finding a replacement for the StorAHCI.sys driver so I might just end up going without MCI unless someone can help. I checked the HP site because this is an old HP Compaq 6200. I couldn't find any updated version or replacement for this driver that will work with Windows 10. This driver has a known issue with Windows 10 with various caused errors, the BSOD, and the hard drive issue. As far as I know Intel hasn't issued a replacement driver either - it seems it is a case of forcing users to buy new hardware if they want a fully capable Windows 10 computer. Does anyone know of a third party replacement or some other update - maybe from Windows?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22