DOWNLOAD: Best tool to repair Windows problems & optimize system performance | Best driver update software for your PC
 
Results 1 to 7 of 7

Thread: enable x-mouse functionality - delay time - windows 7

  1. #1
    warhawks is offline New Member
    Join Date
    Dec 2009
    Posts
    5

    Default enable x-mouse functionality - delay time - windows 7

    ok with Windows 7 I can no longer set the delay time for my "x-mouse" / window hover.

    I know how to get the windows to hover (via the: Control Panel\Ease of Access\Ease of Access Center\Make the mouse easier to use\Activate a window by hovering over it with the mouse), but I want to add a delay (currently it is almost instant in Win 7).

    Anyone know how I can set my own delay? thanks


  2. #2
    Cithel is offline Senior Member
    Join Date
    Nov 2009
    Location
    Omaha, Nebraska USA
    Posts
    168

    Default

    Standard disclaimer: Don't do this if you are not comfortable editing the registry. Back up the registry before doing this. This works fine here but your mileage may vary.

    Using regedit open the regisrty and navigate to the following key:
    HKEY_CURRENT_USER\Control Panel\Desktop\

    Look for: ActiveWndTrkTimeout

    If its there right click and choose modify, change the base to decimal and use a value of about 1500 (1.5 seconds). The value is milliseconds so you can change it to whatever you like but I had some issues with the taskbar acting strange at higher values.

    If ActiveWndTrkTimeout is not there right click in an empty area and choose new dword value. Make sure that you name it exactly: ActiveWndTrkTimeout (yes its case sensitive). Then change it as noted above.

    You will probably need to log off then back on for the change to take effect.

    Best of luck.
    Last edited by Cithel; 22nd December 2009 at 18:27. Reason: Typo on delay time, should have been 1500 not 150. Ooops.

  3. #3
    seti is offline Member
    Join Date
    Nov 2008
    Posts
    1,923

    Default

    Quote Originally Posted by Cithel View Post
    Standard disclaimer: Don't do this if you are not comfortable editing the registry. Back up the registry before doing this. This works fine here but your mileage may vary.

    Using regedit open the regisrty and navigate to the following key:
    HKEY_CURRENT_USER\Control Panel\Desktop\

    Look for: ActiveWndTrkTimeout

    If its there right click and choose modify, change the base to decimal and use a value of about 150. The value is milliseconds so you can change it to whatever you like but I had some issues with the taskbar acting strange at higher values.

    If ActiveWndTrkTimeout is not there right click in an empty area and choose new dword value. Make sure that you name it exactly: ActiveWndTrkTimeout (yes its case sensitive). Then change it as noted above.

    You will probably need to log off then back on for the change to take effect.

    Best of luck.
    Thanks for the tweak. Warning heeded by everyone (I hope)

  4. #4
    warhawks is offline New Member
    Join Date
    Dec 2009
    Posts
    5

    Default

    Quote Originally Posted by Cithel View Post
    Look for: ActiveWndTrkTimeout
    I don't see this, but I do see this:

    ActiveWndTrackTimeout REG_DWORD Hexadecimal Base value is 0

    Is this the same thing?

    PS - I am using Win 7 64-bit Home Professional

  5. #5
    Cithel is offline Senior Member
    Join Date
    Nov 2009
    Location
    Omaha, Nebraska USA
    Posts
    168

    Default

    Quote Originally Posted by warhawks View Post
    ActiveWndTrackTimeout
    Is this the same thing?
    PS - I am using Win 7 64-bit Home Professional
    I can't say with certainty what the ActiveWndTrackTimeout is used for.

    The key that you need to create/modify is ActiveWndTrkTimeout. Both keys exist without any problems thus far on my systems running Vista and 7, both 32 and 64 bit in various versions.

  6. #6
    warhawks is offline New Member
    Join Date
    Dec 2009
    Posts
    5

    Default

    ^^ Ok, that seems to make it work. Thanks Cithel!!

  7. #7
    Cithel is offline Senior Member
    Join Date
    Nov 2009
    Location
    Omaha, Nebraska USA
    Posts
    168

    Default

    Quote Originally Posted by warhawks View Post
    ^^ Ok, that seems to make it work. Thanks Cithel!!
    Glad it works for you

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22