DOWNLOAD: Best tool to repair Windows problems & optimize system performance | Best driver update software for your PC
 
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Windows 7 professional - how to set auto logon

  1. #1
    pdc_2 is offline New Member
    Join Date
    Feb 2010
    Posts
    6

    Default Windows 7 professional - how to set auto logon

    On Windows XP I used the TweakUI tool to set auto logon on my system.
    This doesn't work on Windows 7, so I came upon the Ultimate Windows Tweaker tool.

    Read: How to automatically login to Windows 10.

    Does this tool have the option to set an auto-login?

    Last edited by AshishM; 4th September 2019 at 09:15.

  2. #2
    riteshtechie's Avatar
    riteshtechie is offline Software Developer
    Join Date
    Mar 2009
    Posts
    880

    Default

    You don't need a tool to do that, just follow the below steps -

    1. Press Win + R
    2. In Run dialog box copy paste control userpasswords2 and press enter.
    3. Now User Accounts Window will appear
    4. Click on the name of the user name which you want to set for autologin
    5. Once you have selected your username un-check “Users must enter a user name and password to use this computer"
    6. Now click on the Apply button, the Automatically Log On window
    7. Enter your password and press OK
    8. That's it!!!

    Complete Tut here - http://beingpc.com/2010/02/how-to-au...-in-windows-7/
    Last edited by riteshtechie; 10th February 2010 at 08:55.

  3. #3
    MrMBerman's Avatar
    MrMBerman is offline Senior Member
    Join Date
    Mar 2009
    Location
    Tel Aviv / London / Bukidnon
    Posts
    340

    Default

    OMG! you just solved my home network problems. My netbook could not see my desktop's C drive without entering a password but my desktop is not password protected in any way.

    I have been gaining grey hairs trying to solve this puzzle.

    Un-checking “Users must enter a user name and password to use this computer" has solved my dilemma.

    Thanks buddy

  4. #4
    pdc_2 is offline New Member
    Join Date
    Feb 2010
    Posts
    6

    Default

    Quote Originally Posted by riteshtechie View Post
    You don't need a tool to do that, just follow the below steps -

    1. Press Win + R
    2. In Run dialog box copy paste control userpasswords2 and press enter.
    3. Now User Accounts Window will appear
    4. Click on the name of the user name which you want to set for autologin
    5. Once you have selected your username un-check “Users must enter a user name and password to use this computer"
    6. Now click on the Apply button, the Automatically Log On window
    7. Enter your password and press OK
    8. That's it!!!

    I think this is for the home version of Windows 7, because in my professional version I don't have the check box to check out in the account window...
    Last edited by pdc_2; 10th February 2010 at 10:38.

  5. #5
    MrMBerman's Avatar
    MrMBerman is offline Senior Member
    Join Date
    Mar 2009
    Location
    Tel Aviv / London / Bukidnon
    Posts
    340

    Default

    Quote Originally Posted by pdc_2 View Post
    I think this is for the home version of Windows 7, because in my professional version I don't have the check box to check out in the account window...
    I'm using W7 Pro and the option is there.


  6. #6
    riteshtechie's Avatar
    riteshtechie is offline Software Developer
    Join Date
    Mar 2009
    Posts
    880

    Default

    Quote Originally Posted by pdc_2 View Post
    I think this is for the home version of Windows 7, because in my professional version I don't have the check box to check out in the account window...
    I have ultimate don't know about PRO

  7. #7
    pdc_2 is offline New Member
    Join Date
    Feb 2010
    Posts
    6

    Default

    @ marcEmarc


    Windows club doesn't allow me to post urls, so i can't post a screenprint..
    But the problem is that the line "users must enter a user name and password to use this computer" with the checkbox, is missing from my user account window.

    I allready tried loggin in as administrator offcourse.. makes no difference..
    I'm in a domain, maybe that's what making the difference?

  8. #8
    riteshtechie's Avatar
    riteshtechie is offline Software Developer
    Join Date
    Mar 2009
    Posts
    880

    Default

    1. Go to Start>Run (or press the windows key+r)

    2. Type regedit and press the enter key or click on OK.

    3. In the registry editor go to HKEY_LOCAL_MACHINE>SOFTWARE>Microsoft>Windows NT>CurrentVersion>Winlogon

    4. On right side pane look for these values AutoAdminLogon, DefaultPassword and DefaultUsername. If they are there skip on to Step 6.

    5. If the above values aren’t there, then right click on empty area in the right pane select New>String Value and enter the value name such as AutoAdminLogon. Repeat this step for each value.

    6. Once you’ve created these values double-click each value and enter the following value data for the particular value

    Name : AutoAdminLogon Value : 1
    Name : DefaultPassword Value : the pasword of the user profile
    Name : DefaultUsername Value : the username of the account you want to log in to
    7. Now you’re done!

  9. #9
    HappyAndyK's Avatar
    HappyAndyK is offline Site Administrator
    Join Date
    Jun 2008
    Posts
    7,572

    Default

    Quote Originally Posted by pdc_2 View Post
    Windows club doesn't allow me to post urls, so i can't post a screenprint..
    You can, for the time being, post the url without the http/www

  10. #10
    pdc_2 is offline New Member
    Join Date
    Feb 2010
    Posts
    6

    Default

    @riteshtechie

    This works perfectly, thank you very much. Problem solved.
    Last edited by pdc_2; 10th February 2010 at 15:37.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22