Results 1 to 4 of 4

Thread: Fix: Documents.library-ms is no longer working. This library can be safely deleted

  1. #1
    BarryO is offline New Member
    Join Date
    Mar 2010
    Posts
    2

    Default Fix: Documents.library-ms is no longer working. This library can be safely deleted

    I added documents on an external drive to Documents folder in the Start menu . It was fine but now when I try to open from Start menu I get an error message:



    Documents.library-ms is no longer working. This library can be safely deleted from your computer. Folders that have been included will not be affected.

    Can I fix this ?
    Last edited by BarryO; 8th March 2010 at 20:20.

  2. #2
    MrMBerman's Avatar
    MrMBerman is offline Senior Member
    Join Date
    Mar 2009
    Location
    Tel Aviv / London / Bukidnon
    Posts
    340

    Default

    You can safely delete the missing library. The problem is mapping the new documents shortcut to an external drive, especially if the external drive is not issued the same drive letter on reconnect.

    To set a new shortcut from the start menu there is a quick registry tweak.

    1. Open Registry Editor, type regedit from command line, and navigate to HKEY_LOCAL_MACHINE\SOFTWARE\MICROSOFT\WINDOWS NT\CurrentVersion\ProfileList.

    2. Change the value of the Default, Public, Profile Directory keys to the new location accordingly. ie. G:\Documents

    3. Log off. From this point on, any new user logged in to this computer will have a new user profile that’s located in the new location.



    Hope this helps.

  3. #3
    HappyAndyK's Avatar
    HappyAndyK is offline Site Administrator
    Join Date
    Jun 2008
    Posts
    7,514

    Default

    You could also try to deleting the particular documents library from the explorer LHS pane itself then right click on Libraries, in the LHS pane and select Restore default libraries.

  4. #4
    BarryO is offline New Member
    Join Date
    Mar 2010
    Posts
    2

    Default

    Thanks both , used Andys way as I couldn't work out how to change registry values . It worked

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22