I created a Homegroup on my desktop computer (running Windows 7 Professional, 2.8GHz Intel Quad Core processor, 2GB RAM, 100Mb/s wired network connection), and joined it with my Acer AOD255 netbook (1.5 GHz Intel Atom N550, 2GB RAM, WiFi connection). All worked fine for a while, but then my desktop would no longer load the Homegroup, although the netbook was in it and worked just fine. The Windows Homegroup Troubleshooter told me to delete/leave, and then create/join the Homegroup, so now the netbook isn't in the Homegroup, either.

I've followed all the standard Homegroup troubleshooting as outlined in the Windows Homegroup Troubleshooter, and on Microsoft;s support web site--to no avail. The network is working fine--I can get to the shared folders through conventional means just fine.

I looked at the Homegroup processes on the desktop machine and they refuse to load; giving me errors instead (I'll upload screen shots of the errors later).

Does anyone have any ideas, suggestions or solutions?

Thanks!