DOWNLOAD: Best tool to repair Windows problems & optimize system performance | Best driver update software for your PC
 
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Downloads don't complete in Windows 7 SP1

  1. #1
    Grouch's Avatar
    Grouch is offline New Member
    Join Date
    Mar 2011
    Posts
    7

    Default Downloads don't complete in Windows 7 SP1

    Since I installed Win 7 SP1, I can't complete a download. No matter what browser or application I use, the download hangs before completion. I had this same problem with my desktop PC [x86], but it went away. My laptop [x64] still won't work. If I want a download, I have to download to my desktop PC and put it on a flash-drive to get it to the laptop. I find this VERY disconcerting.
    Any helpful ideas would be greatly appreciated.

    Thanks,
    Grouch

    Last edited by Grouch; 2nd April 2011 at 21:25.

  2. #2
    Grouch's Avatar
    Grouch is offline New Member
    Join Date
    Mar 2011
    Posts
    7

    Default

    As an example, I tried to download "Firefox 4 Final". I restarted at least 10 times. I finally found that when it hung up, if I did a "pause download", "continue download" I could finally get it all. That only works in Firefox because I have the ability to do a "pause/continue" download. Other browsers and other apps don't have that ability. I'll try to tweak (with "SG TCP Optimizer") some of the TCP settings to match what I have on my desktop PC.
    Because I was foolish, and trusted Microsoft, I did a "System Cleanup" after installing SP1. Now, since the install setup files were deleted, I can't back-out the installation of SP1.
    We grow too soon old, and too late smart.

    Thanks,
    Grouch

  3. #3
    roraniel's Avatar
    roraniel is offline Gold Member
    Join Date
    Oct 2008
    Location
    Pinehurst, NC
    Posts
    860

    Default

    Call me paranoid but I think there is a lot going on with a Service Pack and I always do a clean install of Windows and then do the SP update via a disk image before anything else is installed. I have never had an issue doing it this way. It is a lot of work reinstalling everything but I HATE when little annoying things go wrong with my PC's.

  4. #4
    HappyAndyK's Avatar
    HappyAndyK is offline Site Administrator
    Join Date
    Jun 2008
    Posts
    7,572

    Default

    Pls try these and see if it helps:

    Clear Internet cache and try.

    Disable all browser addons and see if it helps.

    See Unable to save or download files - MozillaZine Knowledge Base. Its an old post but perhaps you may find a hint there.

  5. #5
    Grouch's Avatar
    Grouch is offline New Member
    Join Date
    Mar 2011
    Posts
    7

    Default

    @HappyAndyK
    It's not just browsers that fail to complete a download. Apps that have a built-in update feature fail as well. Some offer to download the new version and some download the update and apply the patches themselves. In these cases, (AFAIK) there is no Internet cache to clean.
    In any case, I tried it, and it didn't help.

    Thanks,
    Grouch

  6. #6
    Grouch's Avatar
    Grouch is offline New Member
    Join Date
    Mar 2011
    Posts
    7

    Default

    I have tried tweaking some of the TCP settings, but only got a minor improvement.
    ANY ideas, please!

    Thanks,
    Grouch

  7. #7
    Grouch's Avatar
    Grouch is offline New Member
    Join Date
    Mar 2011
    Posts
    7

    Default Solution

    Finally! I found the problem. It was PCTools firewall. There was a glitch in their driver. The new drivers are available from the PCTools Forum. Just replace the 32 or 64 bit driver in c:\Windows\system32.

    Thanks,
    Grouch

  8. #8
    HappyAndyK's Avatar
    HappyAndyK is offline Site Administrator
    Join Date
    Jun 2008
    Posts
    7,572

    Default

    Thanks for sharing it here

  9. #9
    casper1217 is offline New Member
    Join Date
    Apr 2013
    Posts
    1

    Default I'm having the same problem

    can you post a link to the pctools forum page you found?
    plz

  10. #10
    Grouch's Avatar
    Grouch is offline New Member
    Join Date
    Mar 2011
    Posts
    7

    Default

    Quote Originally Posted by casper1217 View Post
    can you post a link to the pctools forum page you found?
    plz
    I can't remember what it was, It was 2 years ago. It was something to do with their software and the new version resolved the issue. Anything newer than that should work correctly.

    I didn't think anyone used PCTools any more.

    Sorry,
    Grouch

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22