Installed Ubuntu as a second operating system some time back. Since it did not have much appeal to keep me using it, I simply deleted the Ubuntu partition and formatted it. Now it was time to fix the boot menu that asks me which operating system to load.

My fight started at this point. I simply could not find any option to do that. Good old XP had the option to remove or edit operating system properties from within MSCONFIG. When I launched MSCONFIG in Windows 7, it was showing Windows 7. Ubuntu was not there so it should have skipped boot menu upon startup. It did not. As a workaround, I reduced the boot menu time to 3 seconds so that I dont have to press Enter each time I start the computer. Worked but still, looked awkward.

Next step: Tried to locate Boot.ini file but then, Windows 7 does not use it. Trying to create one on my own did not help either. Maybe Windows 7 simply ignores boot.ini.



NEXT: Tried using the Windows Boot Repair option. But no, it was not there either. I remember using the boot disk to boot and press R to start the repair utility. And then we used to enter FIXBOOT followed by FIXMBR and things were perfect. But that was XP again. When I select the repair option after booting from Windows 7 installation disk, all I got was some dialog that kept on running only to ask me if I wish to run System Restore. Turned on and off the computer many times trying to get that command prompt (option was there but then, it was the normal cmd.exe I guess because it wouldn't recognize FIXBOOT or FIXMBR).

FINALLY: Downloaded EasyBCD, deleted the entry related to Ubuntu and selected Skip Boot Menu.

Overall, wasted more than 90 minutes in the exercise. Dear Microsoft, are you playing some kind of "Figure it out" with your users?!