DOWNLOAD: Best tool to repair Windows problems & optimize system performance | Best driver update software for your PC
 
Results 1 to 7 of 7

Thread: X-Fi XtremeGamer

  1. #1
    mspohLFC's Avatar
    mspohLFC is offline Beginner
    Join Date
    Oct 2008
    Location
    Wales, UK
    Posts
    16

    Exclamation X-Fi XtremeGamer

    I am getting crackling and popping noises when using the X-Fi XtremeGamer with Windows Vista. I have noticed that it happens mostly when the Windows start up sound plays. Has anyone actually found a way of sorting this out? Any help would be great!

    Thanks.


  2. #2
    zkestner is offline Beginner
    Join Date
    Jan 2009
    Posts
    14

    Default

    I used to have the same problem with mine, just go to creative's website and download the newest driver for your card. I believe the newest driver fixes this problem.

  3. #3
    mspohLFC's Avatar
    mspohLFC is offline Beginner
    Join Date
    Oct 2008
    Location
    Wales, UK
    Posts
    16

    Default

    Quote Originally Posted by zkestner View Post
    I used to have the same problem with mine, just go to creative's website and download the newest driver for your card. I believe the newest driver fixes this problem.

    Hi,

    Thanks for your reply! The driver that I am using is the Creative Sound Blaster X-Fi series Driver 2.18.0008. I believe that this is the latest driver?

    I am still having problems with it! Creative ****!

    Again, any help would be great!

    Thanks.

  4. #4
    HappyAndyK's Avatar
    HappyAndyK is offline Site Administrator
    Join Date
    Jun 2008
    Posts
    7,572

    Default

    I checked up with a colleague of mine, Vikram, an Xbox MVP - , and he says he had the very same problem and that a driver update as suggested by zkestner had helped him too. So maybe you'd like to uninstall/rollback and try a reinstall.

  5. #5
    mspohLFC's Avatar
    mspohLFC is offline Beginner
    Join Date
    Oct 2008
    Location
    Wales, UK
    Posts
    16

    Exclamation

    Thanks for the advice,

    I've lost count of the number of times that I have uninstalled and reinstalled the driver! I really am dumbfounded by this problem.

  6. #6
    Choto Cheeta's Avatar
    Choto Cheeta is offline Trusted Member
    Join Date
    Jun 2008
    Posts
    136

    Default

    I've lost count of the number of times that I have uninstalled and reinstalled the driver
    Personally, I would suggest to use the drive which is available for the device in Windows update.. Rather than downloading it from Creative web site, continue with the default driver and then search in Windows update to see if new version available or not and if it is there, then continue installation from Windows update

    Thanks.

  7. #7
    mspohLFC's Avatar
    mspohLFC is offline Beginner
    Join Date
    Oct 2008
    Location
    Wales, UK
    Posts
    16

    Default

    Thanks again for the advice! I'm not sure if I wanna risk it anymore to be honest. My computer is running really smoothly at the mo with the onboard sound card so I might just wait. I did read that the crackling and popping noises stop if you turn it to audio creation mode with bit matched playback enabled. Not an ideal scenario if u want to use the other modes etc...Sorry about the rant but I'm just so annoyed!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22