DOWNLOAD: Best tool to repair Windows problems & optimize system performance | Best driver update software for your PC
 
Results 1 to 8 of 8

Thread: Flash and Silverlight will not work on IE

  1. #1
    RainPure's Avatar
    RainPure is offline Beginner
    Join Date
    Oct 2008
    Location
    Avon Park, Florida
    Posts
    15

    Default Flash and Silverlight will not work on IE

    I have Windows Vista Ultimate 64 with all available updates installed on a fairly new computer with 4 gb of memory.

    Neither Flash or Silverlight will work in IE7 or IE8 but they both work fine in Firefox and Chrome.

    I have uninstalled and reinstalled both programs multiple times with the same result.

    Any suggestions would be greatly appreciated.


  2. #2
    HappyAndyK's Avatar
    HappyAndyK is offline Site Administrator
    Join Date
    Jun 2008
    Posts
    7,572

    Default

    Try one OR more of these:

    1) Uninstall Silverlight/Flash. Reset all IE settings to Default through Internet Options. Download & use Microsoft's "Windows Install Cleanup utility". Try to install Silverlight.

    2) Create a system restore point.

    Ensure that IE is closed

    Uninstall Silverlight.

    Remove the registry key HKEY_CLASSES_ROOT\TypeLib\{283C8576-0726-4DBC-9609-3F855162009A} if it exists.

    Then install latest version of Silverlight.

    3) Try installing with Protected Mode / UAC off.

    Let us know how it goes.

  3. #3
    vasudev's Avatar
    vasudev is offline Moderator
    Join Date
    Nov 2008
    Location
    Bangalore
    Posts
    396

    Default

    Are you sure these have been installed? If yes, please check in IE, whether they have been enabled. IE > Tools > Manage Add-Ons> Enable or Disable Add Ons....

    And in Toolbars & extensions, Filters , select , Addons that run without requiring permission and in that see if Silverlight is listed and is enabled , if not right click on it and Enable.

    Similarly for Flash, check Filters and select Downloaded ActiveX controls and look for Shockwave Flash object and Enable if its not.
    Last edited by vasudev; 11th January 2009 at 04:26. Reason: Spelling corrected

  4. #4
    rkonit's Avatar
    rkonit is offline Gold Member
    Join Date
    Jul 2008
    Location
    Pilani, India
    Posts
    1,363

    Default

    try !! as directed above posts.

    You're running Vista x64 edition n as far as I know Adobe aint released 64bit flash active x add on for IE x64.

    If you have already installed Flash Active X for IE then try IE 32bit edition...it'll work all way.

  5. #5
    seti is offline Member
    Join Date
    Nov 2008
    Posts
    1,923

    Default

    Ramesh is correct there isn't a 64 bit flash but you can still run it in the the 32 bit version without problems. I use this quite a lot when I encounter this problem. Also you should have silverlight 2 installed as well. All your favorites and setting are on both versions of IE. So just go to start and rather then the IE 64 bit in programes go to IE and use that. Alternatively if you have the IE tab in Firefox (and why not if you don't) then use that as that is the 32 bit version of IE

  6. #6
    HappyAndyK's Avatar
    HappyAndyK is offline Site Administrator
    Join Date
    Jun 2008
    Posts
    7,572

    Default

    Vasudev is a Windows Live MVP and his word means a lot on 'live-ly' issues

  7. #7
    nesimtunc is offline New Member
    Join Date
    Sep 2009
    Posts
    1

    Default

    Just turn off Proctected Mode on IE. If doesn't work add the web site to Trusted Sites.

  8. #8
    rkonit's Avatar
    rkonit is offline Gold Member
    Join Date
    Jul 2008
    Location
    Pilani, India
    Posts
    1,363

    Default

    Reply on quite old thread...but I suggest>>

    Don't turn off Proctected Mode on IE. It is must be Turn On.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22