DOWNLOAD: Best tool to repair Windows problems & optimize system performance | Best driver update software for your PC
Results 1 to 3 of 3

Thread: USB Flash Drive Unaccessible

  1. #1
    LeeW is offline Gold Member
    Join Date
    Jan 2010

    Question USB Flash Drive Inaccessible

    I have a PNY 4GB Swing Drive that I've only had a few month's and have only used it maybe 3 or 4 times. I am running Windows 7 Premium and I have a Tablet with WindowsXP SP3. Tonight I used the drive to move a program over to the Tablet from my main PC and afterwards I put the drive back into my main pc to put a iso on it and what do you know. I have been bit by the flashdrive bug.

    : Inserting flashdrive, the pc responds as always by saying it has safely installed the drive and it is working correctly
    : After it has installed correctly I go to My Computer and wala no Removeable Media (I have empty drives hidden). I unhid the drives and it shows up just as it always does, except its showing as empty
    : Clicking the drive gives me the Insert Disk Error
    : Going to Device Manager displays the drive with it's factory name
    : Going to Disk Management it displays but shows 0% of 0% disk space used
    : I cannot format since it won't let me, and I have downloaded 5 different tools to try to fix it and do low level formats and all do the same thing. They recognize the drive as being there but will not allow access saying Insert Media
    : Everything points to the drive as being the problem as if it has decided to forget what it is and what's it for
    : I have also tried Reassigning Drive Letters. Restoring Services just to make sure, checked the Registry settings, switching to different computers, everything I could possibly think of aside from tossing this thing in the trash

    The flashdrive is a 4GB PNY Attache Micro Swing.

    No breaks, dents, scratches, and hasn't been dropped,chewed on, stepped on, or (thrown). All other drives work such as my SD cards and such

    Anyone have any ideas, aside from tossing it, or pointing towards PNY. I have allready contacted them waiting to see what they would say but my faith in PNY is gone after downloading their Utility which btw for anyone out there, their utility is outdated and only runs on machines up to XP

    (Excuse my humor, been up all night working on the Tablet and double tasking trying to fix this, now 5am and I'm slightly sleep deprived

    Thanks to anyone with any input
    Last edited by LeeW; 6th February 2010 at 16:26.

  2. #2
    rkonit's Avatar
    rkonit is offline Gold Member
    Join Date
    Jul 2008
    Pilani, India


    Use Diskpart Utility to clean the volumes and re-create partition.

    DISKPART> List disk
    displays all available disks on Computer, suppose your pen drive is disk 1

    DISKPART> Sel disk 1
    it will select the disk 1 to perform disk operations

    DISKPART> Clean All
    clean everything data, volume, partition may take time, depends upon your system speed.

    DISKPART> Create Part Primary
    create a primary partition

    DISKPART> Format Recommended
    formats your pen drive with recommended settings like file system, sectors etc.

    its done...if you found your device in Computer.
    otherwise try it
    it will assign a available drive letter to your pen drive

  3. #3
    LeeW is offline Gold Member
    Join Date
    Jan 2010


    Tried diskpart. It picks up the pen drive when i insert it but it gives says no media.
    any command I try to give to the pen drive gives me a no volume specified. I believe I know what happened. I'm used to vista and seven where you don't have to safely remove media. I put the pen drive in my gf's tablet which had xp sp3 installed and i didn't hit safely remove before i pulled the pen drive out of it. I thought about it some and I realized that after pulling pen drive from tablet is when it went poof

    I bought another pendrive so I'm good. Tomorrow when I get access to a Linux system I am going to try getting the linux system to pick it up. I have heard there's alot more success recovering pen drives through linux than Windows so we shall see, if not o well, the 4GB pen drive is cheap as dirt nowdays.

    Thanks Ramesh for the input. I had heard of Diskpart but never used it. Good to have in the future

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22