Hello everyone,

This is my first post here but I've used this site many times before in the past for various things. That said, I hope someone can help me here as I have kind of an odd problem and have hit a wall with it. Truly, any advice at this point would be most appreciated! I do wish to apologize ahead of time for what will probably be a lengthy post but it all seemed pertinent to the issue and I wanted to detail what I've already attempted as to not unnecessarily waste anyone's time.

Three days ago, I purchased 2 PNY USB 3.0 128 GB flash drives. I purchased them both from Best Buy at the same time and they are both entirely identical as far as I can tell; physical appearance, the packaging and UPC are all the same.

When I went to format them, I did the first one as NTFS via File Explorer (right click, format), with the default allocation size and quick format unselected. Once finished and I went to move files onto it, my transfer speeds were slow and really inconsistent (it would start around 50 MB/s, which is about what I had hoped for, but quickly dropped closer to 20 MB/s on average, occasionally even bombing to 200 KB/s or less for stretches at a time). This did not seem right to me, so I went to Google to see if I could troubleshoot the problem.

First, the advice revolved around simple and redundant stuff such as checking to make sure my USB 3.0 was enabled in the BIOS (it was), the flash drive was plugged into the blue USB 3.0 rear ports (it was) and making sure my drivers were up-to-date. Admittedly, updating my drivers was kind of a headache because my USB 3.0 driver kept disappearing for some reason, but my assumption was Windows 10 did not like my manually downloaded and installed VIA USB 3.0 driver, instead wanting to use its own and there was some trial and error involved before I was able to resolve it. From there, I read about the different format options. The opinions people had did seem kind of mixed, but the consensus seemed to be exFat would provide faster and more consistent speeds over NTFS (which is what I used to format the first drive). My only available format options for the drives were exFat or NTFS, so when I did my 2nd flash drive I formatted it the same way but with exFat (in File Explorer, default allocation size and quick format unselected).

When my 2nd drive was completed, I moved some files over and while it was somewhat faster, it wasn't by much. When I read more, some people recommended selecting "better performance" over "quick removal" in the policies tab on the drive in device manager. This advice helped; my first, NTFS formatted drive was now around 35 MB/s on average and my second, exFat formatted drive around 50 MB/s. However, when I went to use the exFat formatted drive on my families USB enabled DVD player, it did not recognize the exFat format, which basically forced my hand into using NTFS on both. Without much of a choice then, I went back and reformatted the 2nd flash drive from exFat to NTFS, this time in File Explorer, format, with 8,192 as the allocation size and quick format selected. From here is when the problem started.

The first flash drive which was initially done as NTFS has 124 GB of available space, whereas the second, originally done as exFat and then redone as NTFS, only has 118 GB of available space for some reason. I wasn't sure why, so I did more research hoping to correct the problem. I have since attempted to run disk part on the 2nd drive multiple different times. I have run clean, clean all, create partition primary and every other combination I could find attempting to reacquire the lost space. Nothing has worked. The 2nd flash drive consistently comes back as 118 GB available. I pressed on, attempting to wipe it clean in disk management. I have attempted to uninstall the drivers and clueless, even attempted disabling it in device manager hoping it would do something for some reason. I have attempted to reformat it both in disk management and in precisely the same way as the first drive: File Explorer, format, NTFS, default allocation size, quick format unselected. Despite all of this, it comes back the same. I've even attempted some 3rd party software such as Boot-It and BootIce, albeit very briefly.

Obviously frustrated with it at this point, I was about ready to cut my losses and chalk it up to data corruption or whatever else but I'm inclined to think there is something else happening because the two flash drives, which should be identical at this point, simply aren't. When I open the properties for the first drive initially formatted as NTFS, it has both the "Compress this drive to save disk space" and "Allow files on this drive..." options, whereas the 2nd drive only has "Allow files on this drive..." available. In addition, in the security tab, the first drive displays "Authenticated Users, SYSTEM, Administrator and Users," whereas the 2nd drive only displays "Everybody."

I have attempted this on the 2nd drive (and it makes no difference):

CMD.exe > Run as admin > diskpart > list disk > select disk > clean (as well as clean all) > exit

CMD.exe > Run as admin > diskpart > list disk > select disk > list partition > select partition > clean (as well as clean all) > exit

CMD.exe > Run as admin > diskpart > list disk > select disk > list volume > clean (as well as clean all) > exit

I've attempted variations of the above with create partition primary and formatting it in both disk part with the "format fs=NTFS" command, as well as in disk management itself. As I approached the end of my patience with it, I even attempted swapping it between my different USB 3.0 ports (I have two USB 3.0 ports connected directly to my motherboard in back that I primarily use, as well as two in front). None of it works. When I reformat the 2nd flash drive as NTFS, regardless of the allocation size I assign it or whether it's done as a quick format or not, it comes back with 118 GB of available space and the "Compress this drive..." and security properties different from the other drive. As my last resort, I even attempted to reformat the first flash drive exactly the same as the 2nd (done back to back in the exact same USB 3.0 port) and the first drive comes up with the normal 124 GB of free space and NTFS "Compress this drive..." and full security options available.

That all said, there is one oddity with the first flash drive as well: when I view it in disk management, it lists it as an active drive for some reason. I did not format it that way, nor did I ever enable it (at least not deliberately). Clearly that isn't correct either, as my primary SSD is my boot / active drive.


Anyway, I'm completely stumped and at my wit's end, so it seemed like it was worth a shot posting here and hopefully receiving some advice or input on the situation. To be honest I don't even care that much about the storage discrepancy at this point as much as simply wanting to know what the problem is, what it could be or what I potentially screwed up, so I don't make the same mistake in the future. While I would obviously prefer both worked properly, I've also learned (especially from using Windows for many years) that stuff is simply broken sometimes and you pretty much just have to deal with it.

Again, any advice would be very appreciated at this point. Thank you very much for your time.