DOWNLOAD: Best tool to repair Windows problems & optimize system performance | Best driver update software for your PC
Results 1 to 3 of 3

Thread: Faulty network adapter

  1. #1
    MicroKid is offline New Member
    Join Date
    Jan 2011

    Default Faulty network adapter

    I have a Lenovo G70 laptop and been having problems with my wifi and cannot find a solution.
    My network was set to connect automatically at start-up. After a while it was taking longer
    to connect and then I had to connect manually and now it wont connect at all and I have to use
    my ethernet cable. When I manually connect I enter my password and it says "cannot connect".
    There is no yellow or red warning on wifi icon. I have tried everything so I have come
    to the conclusion that my Qualcomm Atheros AR956X Wireless Network Adapter is faulty but
    what confuses me is that it shows a list of networks to connect to.

    I cannot assume its my BThomehub5.0 as my other devices connect to it with no problems.

    I have tried the following and in no particular order:

    1. Reset Network
    2. Changed DNS
    3. Forgot my network and re-entered password
    4. System Restore.
    5. Router power cycle
    6. Command prompt "netsh int ip reset resetlog.txt", "shutdown /r /t 00"
    7. Uninstalling the Qualcomm driver and rebooting
    8. Troubleshooting the wifi network

    Doing all the above without success I decided to reset my laptop and reinstall windows with a
    clean installation hoping that that might solve it but after a few hours installation the wirelesss
    network still doesn't connect.

    As I mentioned earlier I think my network adapter is faulty but why does it still show a list of networks?
    I could replace it with a new adapter but it has to be Lenovo approved with the same FRU s/n
    which has to be included in the whitelist which is embeded in the Bios which I don't know much about.
    I thought about buying a usb wireless wifi adapter.

  2. #2
    HappyAndyK's Avatar
    HappyAndyK is offline Site Administrator
    Join Date
    Jun 2008


    You seem to have tried it all. I think it is your Network Adapter that may be the cause.

    Perhaps you could show your PC to a hardware technician.

  3. #3
    MicroKid is offline New Member
    Join Date
    Jan 2011


    I have bought a USB Wireless Adapter to save the hassle.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22