DOWNLOAD: Best tool to repair Windows problems & optimize system performance | Best driver update software for your PC
 
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Windows Update Not working after Vista SP2 - Get blank window

  1. #1
    aweysham is offline New Member
    Join Date
    May 2009
    Location
    Chiang Mai, Thailand
    Posts
    7

    Smile Windows Update Not working after Vista SP2 - Get blank window

    I successfully installed SP2 for vista via Win Upate, thought all was OK except now I notice Win Update does not work. I get a blank window when I select Win Update., also tried to change setitngs to no avail. Other than that all is OK.
    Im running Vista Business, Asus U6Sg, 2.5 ghz, 3g ram, Norton Internet Security.

    I keep the computer real clean and had defragged and ran scans before install SP2 so I could see if there was any HD gain, yes gained 37g.

    any ideas other than restore before SP2?


  2. #2
    HappyAndyK's Avatar
    HappyAndyK is offline Site Administrator
    Join Date
    Jun 2008
    Posts
    7,572

  3. #3
    seti is offline Member
    Join Date
    Nov 2008
    Posts
    1,923

    Default

    After doing what Andy say, my suggestion is that there are no updates available to you at the moment. I am using Ultimate and there are not any for me right now

  4. #4
    aweysham is offline New Member
    Join Date
    May 2009
    Location
    Chiang Mai, Thailand
    Posts
    7

    Default

    Thanks for the quick reply guys. Happy Andy, yes my update window looks just like the one in the link you sent me. I did as you said and on first entry (regsvr32 jscript) in "RUN" I got an error code (sorry forgot the number). researched that code fix and it said to disable UAC which I did and then re ran the first entry again successfully. Ran the second one, vbscript, successfully. then ran the third one and got this message:
    "module "mshtml" was loaded but the entry point DLLRegisterServer was not found. make sure that mshtml is a valid DLL or OCX file and then run again".
    so looks like Im partially there.

    @ Seti, thanks for your reply and thought that may be the case too but the window is not the usual window when there are no updates. Looks like Im almost there. also Im not sure if it was SP2 installation that did it. seems I reemember checking updates days after install SP2 and all was OK then.

  5. #5
    HappyAndyK's Avatar
    HappyAndyK is offline Site Administrator
    Join Date
    Jun 2008
    Posts
    7,572

  6. #6
    leofelix is offline Member
    Join Date
    Oct 2008
    Location
    Italy
    Posts
    1,668

    Default

    Hi welcome awaysham,
    Did you try to temporarily disable NIS 2009?
    I've read that some people got problems with Vista SP2 and Norton

  7. #7
    knightrider™'s Avatar
    knightrider™ is offline Gold Member
    Join Date
    Jul 2008
    Location
    India
    Posts
    754

    Default

    yah remove norton ... and put nod32 no issues...

  8. #8
    aweysham is offline New Member
    Join Date
    May 2009
    Location
    Chiang Mai, Thailand
    Posts
    7

    Angry

    Wow! 2 suggestions regarding Norton. I love the program but will give that a try.

  9. #9
    aweysham is offline New Member
    Join Date
    May 2009
    Location
    Chiang Mai, Thailand
    Posts
    7

    Default

    Solved for now. My solution:
    I had suggestions that Norton Internet Security was the problem. Researched that on the net. Disabled NIS 09' temporarily to no avail. Finally decided to uninstall SP2 (as per ScottW suggestion, thanks). Problem cleared up immediately. Win Update works. Now that Update works it does not list SP2 as an update as it did before. Strange?? Now it list "System Update Readiness Tool" only. From now on I will keep a very good log of what I install and when.

    Now some may say SP2 is more important than NIS. Not for me. I love NIS and what it does for me. I've been using Vista with SP1 for long time and have all the initial bugs worked out of Vista thanks to lots of help and hacks from people like on this and other forums. Lots of very smart people out there. So I'll stick with SP1 and NIS 09'. I'll continue to research the problem though. I kept SP2 for Office and MS Projects. Regards the hd space gained, yes I gained 37g when installed SP2 and still have a gain of 21g after uninstall SP2.

    Many thanks to all who gave me their suggestions. Very much appreciated.

  10. #10
    tweakwindows's Avatar
    tweakwindows is offline Microsoft MVP
    Join Date
    Jul 2008
    Location
    intowindows.com
    Posts
    1,285

    Default

    ^ You might have not have given try to Windows Update Error Fixer tool from MS Fix It team. It resets all the settings to the default. Very useful tool.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22