If you don't want the windows to catch the edges of the screen when u drag'em there, you can disable this by following the steps below:



Disabling Mouse Window Drag Arranging

Open up your Control Panel, and then go to the Ease of Access center. From there, click on "Make the mouse easier to use"…



And then remove the checkbox for "Prevent windows from being automatically arranged when moved to the edge of the screen", and then click the Apply button to actually save the setting.



Source- HowToGeek.