DOWNLOAD: Best tool to repair Windows problems & optimize system performance | Best driver update software for your PC
Results 1 to 1 of 1

Thread: Help. GPT Boot SSD suddenly converted to MBR?

  1. #1
    Phoebe is offline Beginner
    Join Date
    May 2015

    Default Help. GPT Boot SSD suddenly converted to MBR?

    I would like to ask computer expert here, look at what‘s the problem? how to solve it? I have asked someone else, Nobody knows
    So I've been running Windows Server Techincal Preview 2 and had it installed on a 240 GB Crucial SSD. A couple of days ago I ran Windows UPdate from the Sconfig option 6 and downloaded and installed the updates that it found. It said a reboot was required and I clicked OK to reboot. So it rebooted and then upon it trying to boot up again I started getting winload.efi not found errors and BSOD. Further investigation using 3rd party partitioning programs show that my previously formatted GPT disk is now listed as basic MBR disk. What would have done that? All the data is the same and the partitions themselves are the same. I used one of the guides here on Technet to initially setup and format the disk to the 4 partition (1 including hidden MSR partition). Format style was as such:

    EFI partition-fat32 (Hidden)

    MSR partition -"other"(Hidden

    Windows partition- ntfs

    Recovery -ntfs

    diskpart and 3rd party programs don't show the MSR so it looks like only 3 partitions.

    But with everything still the same, how the heck did it just convert to MBR disk?

    A similar issue is noticed as well. I use the EASEUS partition master server edition program which includes ability to make a bootable PE disk. When I boot to that disk I am also seeing a 1MB unallocated partition showing on my disks. It is also affecting a couple of Basic MBR disks as well but in those cases I can move that partition to cover that 1 MB unallocated space. On GPT disk however I can get my self stuck in that I cannot move or extend the EFI or MSR partition and cannot get disk to allign so that there is no mysterious unallocated 1 MB partition. EASUS was trying to say that the 1mb partiton could be part of the EFI partition, but Ive never had other bootable GPT disks that would show up this way.

    So the situation I'm in now is that I can't get rid of the unallocated 1mb space that is showing in partition programs, my disk is mysteriously now MBR for some reason and I can't boot anymore to the server as computer still boots it as UEFI GPT disk and I keep getting winload.efi BSOD or even worse getting tons of DPC_Watchdog Violation errors before I can boot to anything.

    I know some of the DPC errors related to having some USB ports occupied but still persists even with nothing else attached. I am attempting to rebuild the disk as GPT again by copying the windows partition and recovery partition to a blank external disk and then wiping the SSD and re-initializing as GPT. Will then re-create the EFI and MSR partition and then copy back the Wiindows and recovery partition.

    So I did most of that but caused another issue where I may have misread the instructions somewhere. I was told that for each GPT disk that you wanted to be bootable had to have its own MSR and EFI partition. Now when I attempt to use BCDboot or BCDedit I get a strange message about not being able to find winload.efi or related due to multiple instances of idendical paths . Setting the path to the correct EFI are not working. Removed those other GPT disks yet cannot run bcdboot or bcdedit or really do any work on my bcd as keep getting

    "the requested systemdevice cannot be identified due to multiple indistinquishable devices potentially matching the identification criteria".

    even after deleting and removing all other EFI system partitions the system will still not boot with winload.efi errors and cannot fix or work on any boot files as always get above.

    Last 2 questions, What happened to bootrec.exe? When I attempt to boot to the ISO for Technical Preview and run boot rec from the EFI or Windows partition I will often get something stating bootrec not recognized.

    Finally, DISM is reading the ISO files as they would be with Windows Server 2012 R2 and are showing the indexes as 4 instead of 2. I didn't do anything different and is the same ISO and burned to DVD that previously showed 2 indexes and was the ISO used to install the OS to begin with. Why is -get-wiminfo showing that ISO as Server 2012R2 now with 4 indexes?

    All in all I'm baffled and confused and nothing seems to be working. I'd love it if someone could help with DPC Watchdog violation BSOD. How am I supposed to fix it if I cant even boot to a DVD or what have you without the error coming in? I've never seen a BSOD for winload.efi before when trying to boot to a DVD but that is also happening.
    Last edited by Phoebe; 18th June 2015 at 01:50.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22